# New sensu go installation

**URL:** <https://discourse.sensu.io/t/new-sensu-go-installation/1549>\
**Category:** Sensu Go\
**Created:** [December 31, 2019, 7:25am UTC](https://discourse.sensu.io/t/new-sensu-go-installation/1549 "2019-12-31T07:25:08Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![vipinm](https://avatars.discourse-cdn.com/v4/letter/v/f07891/32.png) [@vipinm](https://discourse.sensu.io/u/vipinm)\
**Post date:** [December 31, 2019, 7:25am UTC](https://discourse.sensu.io/t/new-sensu-go-installation/1549/1 "2019-12-31T07:25:08Z")

</div>

hi All,

I am unable to set logins for new sensu go installation.

[root@ip-10-1-160-159 ~]# netstat -plan | grep 808  
tcp 0 0 127.0.0.1:52412 127.0.0.1:8080 TIME\_WAIT -  
tcp 0 0 127.0.0.1:49440 127.0.0.1:8081 TIME\_WAIT -  
tcp6 0 0 :::8080 :::\* LISTEN 13281/sensu-backend  
tcp6 0 0 :::8081 :::\* LISTEN 13281/sensu-backend  
[root@ip-10-1-160-159 ~]#  
[root@ip-10-1-160-159 ~]# sensuctl configure -n --username ‘admin’ --password ‘P@ssw0rd!’ --namespace default --url ‘[http://127.0.0.1:8080](http://127.0.0.1:8080)’

Error: unable to authenticate with error: Unauthorized

Also tried below way,

[root@ip-10-1-160-159 ~]# sensuctl configure  
? Sensu Backend URL: [http://127.0.0.1:8080](http://127.0.0.1:8080)  
? Username: admin  
? Password: \*\*\*\*\*\*\*\*\*  
? Namespace: default  
? Preferred output format: tabular

Error: unable to authenticate with error: Unauthorized

[root@ip-10-1-160-159 ~]#

can someone help me

---

<div class="post-metadata">

**Author:** ![asombie](https://avatars.discourse-cdn.com/v4/letter/a/e9bcb4/32.png) [@asombie](https://discourse.sensu.io/u/asombie)\
**Post date:** [August 12, 2021, 5:21pm UTC](https://discourse.sensu.io/t/new-sensu-go-installation/1549/3 "2021-08-12T17:21:48Z")

</div>

Hello Todd,  
I am having the same issue after installing sensu-backend and agent on the same machine running centos7. I have initialize the backend.

After doing the following:  
export SENSU\_BACKEND\_CLUSTER\_ADMIN\_USERNAME=  
export SENSU\_BACKEND\_CLUSTER\_ADMIN\_PASSWORD=  
sensu-backend init

I am able to access " [http://localhost:3000](http://localhost:3000)

However, i am getting the following errors =\>

**# sensuctl**  
Error: Unable to locate credentials. You can either configure credentials by running “sensuctl configure” or by using the --api-key command line option

then =\>

**# sensuctl configure**  
? Authentication method: username/password  
? Sensu Backend API URL: [http://127.0.0.1:8080](http://127.0.0.1:8080)  
? Namespace: default  
? Preferred output format: tabular  
? Username: admin  
? Password: \*\*\*\*\*\*\*\*\*

**Error: unable to authenticate with error: Unauthorized**

Any helps is greatly appreciate.  
Thank you again for your help

---

<div class="post-metadata">

**Author:** ![Luc\_Dandoy](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.sensu.io/luc_dandoy/32/150_2.png) [@Luc\_Dandoy](https://discourse.sensu.io/u/Luc_Dandoy)\
**Post date:** [August 24, 2021, 7:31pm UTC](https://discourse.sensu.io/t/new-sensu-go-installation/1549/4 "2021-08-24T19:31:00Z")

</div>

Strange.  
I did a fresh install on centos7 just to see if I can reproduce your issue:

```auto
curl -s https://packagecloud.io/install/repositories/sensu/stable/script.rpm.sh | sudo bash
....
yum install -y sensu-go-backend sensu-go-agent sensu-go-cli
...
curl -L https://docs.sensu.io/sensu-go/latest/files/backend.yml -o /etc/sensu/backend.yml
service sensu-backend start
export SENSU_BACKEND_CLUSTER_ADMIN_USERNAME=admin
export SENSU_BACKEND_CLUSTER_ADMIN_PASSWORD=P@ssw0rd0
sensu-backend init
systemctl stop firewalld # to be able to connect to the VM on port 3000

```

As connection with WebUI is OK I have the same thing as you do. So lets try sensuctl configure:

```auto
> sensuctl configure
? Authentication method: username/password
? Sensu Backend API URL: http://localhost:8080
? Namespace: default
? Preferred output format: tabular
? Username: admin
? Password: *********

> sensuctl namespace list
   Name    
───────────
  default  

```

No issue at all.  
Would it be possible to look at your backend.yml? In my test I used the one from the doc without modifying anything
