# "sensu must be a hash" error while starting sensu-server

**URL:** <https://discourse.sensu.io/t/sensu-must-be-a-hash-error-while-starting-sensu-server/750>\
**Category:** Sensu Classic (EOL)\
**Created:** [January 23, 2017, 11:19am UTC](https://discourse.sensu.io/t/sensu-must-be-a-hash-error-while-starting-sensu-server/750 "2017-01-23T11:19:40Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Marius\_Pfeffer](https://avatars.discourse-cdn.com/v4/letter/m/9fc348/32.png) [@Marius\_Pfeffer](https://discourse.sensu.io/u/Marius_Pfeffer)\
**Post date:** [January 23, 2017, 11:19am UTC](https://discourse.sensu.io/t/sensu-must-be-a-hash-error-while-starting-sensu-server/750/1 "2017-01-23T11:19:40Z")

</div>

I’m trying to get sensu working on a Fedora 24 Xfce machine, according to this tutorial: [http://techblog.geir.io/standalone-sensu-server-on-centos7](http://techblog.geir.io/standalone-sensu-server-on-centos7)

But starting sensu-server fails via systemct:

[neo@localhost ~]$ systemctl status sensu-server

● sensu-server.service - LSB: Sensu monitoring framework server

Loaded: loaded (/etc/rc.d/init.d/sensu-server; bad; vendor preset: disabled)

Active: failed (Result: exit-code) since Mon 2017-01-23 12:08:26 CET; 5min ago

Docs: man:systemd-sysv-generator(8)

Process: 1159 ExecStart=/etc/rc.d/init.d/sensu-server start (code=exited, status=1/FAILURE)

Jan 23 12:08:25 localhost.localdomain sensu-server[1159]: {“timestamp”:“2017-01-23T12:08:25.868351+0100”,“level”:“warn”,“message”:“loading config file”,“file”:"/etc/sensu/conf.d/uchiwa.json"}

Jan 23 12:08:25 localhost.localdomain sensu-server[1159]: {“timestamp”:“2017-01-23T12:08:25.868408+0100”,“level”:“warn”,“message”:“config file applied changes”,“file”:"/etc/sensu/conf.d/uchiwa.json",“changes”:{“uchiwa”:[null,{“host”:“0.0.0.0”,“port”:3000,“refresh”:5,“user”:“admin”,“pass”:“REDACTED”}]}}

Jan 23 12:08:25 localhost.localdomain sensu-server[1159]: {“timestamp”:“2017-01-23T12:08:25.868473+0100”,“level”:“fatal”,“message”:“sensu must be a hash”,“object”:[{“name”:“Datacenter 1”,“host”:“localhost”,“port”:4567},{“name”:“DataCenter 1”,“host”:“127.0.0.1”,“port”:4567}]}

Jan 23 12:08:25 localhost.localdomain sensu-server[1159]: {“timestamp”:“2017-01-23T12:08:25.868509+0100”,“level”:“fatal”,“message”:“SENSU NOT RUNNING!”}

Jan 23 12:08:25 localhost.localdomain runuser[1170]: pam\_unix(runuser:session): session closed for user sensu

Jan 23 12:08:26 localhost.localdomain sensu-server[1159]: [17B blob data]

Jan 23 12:08:26 localhost.localdomain systemd[1]: sensu-server.service: Control process exited, code=exited status=1

Jan 23 12:08:26 localhost.localdomain systemd[1]: Failed to start LSB: Sensu monitoring framework server.

Jan 23 12:08:26 localhost.localdomain systemd[1]: sensu-server.service: Unit entered failed state.

Jan 23 12:08:26 localhost.localdomain systemd[1]: sensu-server.service: Failed with result ‘exit-code’.

Any ideas?

[api.json](https://discourse.sensu.io/uploads/short-url/nPV4yJmC3CuGuamkdBevG48Nokc.json) (84 Bytes)

[client.json](https://discourse.sensu.io/uploads/short-url/pU7qkl81Aakb2OJ5PvTny6IKi6o.json) (247 Bytes)

[dashboard.json](https://discourse.sensu.io/uploads/short-url/bOh3uHpfJwOsVLMFX1aPOY0Eg3m.json) (171 Bytes)

[redis.json](https://discourse.sensu.io/uploads/short-url/3Oxc6LZ6BKzUCY3jjroafJS95OX.json) (63 Bytes)

[transport.json](https://discourse.sensu.io/uploads/short-url/sE8KSidKpw9BNUwEqScXTWo9olw.json) (77 Bytes)

[uchiwa.json](https://discourse.sensu.io/uploads/short-url/poLo5YxMyflwUSIxKHKFDZMMvwW.json) (229 Bytes)

---

<div class="post-metadata">

**Author:** ![Shanker\_Balan](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.sensu.io/shanker_balan/32/84_2.png) [@Shanker\_Balan](https://discourse.sensu.io/u/Shanker_Balan)\
**Post date:** [January 23, 2017, 2:18pm UTC](https://discourse.sensu.io/t/sensu-must-be-a-hash-error-while-starting-sensu-server/750/2 "2017-01-23T14:18:33Z")

</div>

Comments inline.

> **···**
>
> > On 23-Jan-2017, at 4:49 PM, Marius Pfeffer \<pfeffer.marius@gmail.com\> wrote:
> > 
> > I'm trying to get sensu working on a Fedora 24 Xfce machine, according to this tutorial: [http://techblog.geir.io/standalone-sensu-server-on-centos7](http://techblog.geir.io/standalone-sensu-server-on-centos7)
> > 
> > But starting sensu-server fails via systemct:
> > 
> > [neo@localhost ~]$ systemctl status sensu-server  
> > ● sensu-server.service - LSB: Sensu monitoring framework server  
> > &nbsp;&nbsp;&nbsp;Loaded: loaded (/etc/rc.d/init.d/sensu-server; bad; vendor preset: disabled)  
> > &nbsp;&nbsp;&nbsp;Active: failed (Result: exit-code) since Mon 2017-01-23 12:08:26 CET; 5min ago  
> > &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Docs: man:systemd-sysv-generator(8)  
> > &nbsp;&nbsp;Process: 1159 ExecStart=/etc/rc.d/init.d/sensu-server start (code=exited, status=1/FAILURE)
> > 
> > Jan 23 12:08:25 localhost.localdomain sensu-server[1159]: {"timestamp":"2017-01-23T12:08:25.868351+0100","level":"warn","message":"loading config file","file":"/etc/sensu/conf.d/uchiwa.json"}  
> > Jan 23 12:08:25 localhost.localdomain sensu-server[1159]: {"timestamp":"2017-01-23T12:08:25.868408+0100","level":"warn","message":"config file applied changes","file":"/etc/sensu/conf.d/uchiwa.json","changes":{"uchiwa":[null,{"host":"0.0.0.0","port":3000,"refresh":5,"user":"admin","pass":"REDACTED"}]}}  
> > Jan 23 12:08:25 localhost.localdomain sensu-server[1159]: {"timestamp":"2017-01-23T12:08:25.868473+0100","level":"fatal","message":"sensu must be a hash","object":[{"name":"Datacenter 1","host":"localhost","port":4567},{"name":"DataCenter 1","host":"127.0.0.1","port":4567}]}  
> > Jan 23 12:08:25 localhost.localdomain sensu-server[1159]: {"timestamp":"2017-01-23T12:08:25.868509+0100","level":"fatal","message":"SENSU NOT RUNNING!"}  
> > Jan 23 12:08:25 localhost.localdomain runuser[1170]: pam\_unix(runuser:session): session closed for user sensu  
> > Jan 23 12:08:26 localhost.localdomain sensu-server[1159]: [17B blob data]  
> > Jan 23 12:08:26 localhost.localdomain systemd[1]: sensu-server.service: Control process exited, code=exited status=1  
> > Jan 23 12:08:26 localhost.localdomain systemd[1]: Failed to start LSB: Sensu monitoring framework server.  
> > Jan 23 12:08:26 localhost.localdomain systemd[1]: sensu-server.service: Unit entered failed state.  
> > Jan 23 12:08:26 localhost.localdomain systemd[1]: sensu-server.service: Failed with result 'exit-code'.
> > 
> > Any ideas?
> 
> Did you have by any chance uchiwa.json and dashboard.json under /etc/sensu/conf.d? I dont  
> have a dashboard.json but uchiwa.json is at /etc/sensu and not under /etc/sensu/conf.d/.
> 
> Do try moving the said config out of /etc/sensu/conf.d.
> 
> Regards.  
> @shankerbalan

---

<div class="post-metadata">

**Author:** ![Marius\_Pfeffer](https://avatars.discourse-cdn.com/v4/letter/m/9fc348/32.png) [@Marius\_Pfeffer](https://discourse.sensu.io/u/Marius_Pfeffer)\
**Post date:** [January 23, 2017, 4:19pm UTC](https://discourse.sensu.io/t/sensu-must-be-a-hash-error-while-starting-sensu-server/750/3 "2017-01-23T16:19:30Z")

</div>

Thanks, that was it (partially).

I’ve got another error saying “level”:“fatal”,“message”:“could not write to pid file”,“pid\_file”:“/var/run/sensu/sensu-server.pid”, so I’ve changed the user and group of /var/run/sensu from root to sensu.

And enabled and started uchiwa.

But it seems to run so far.

> **···**
>
> Am Montag, 23. Januar 2017 15:18:44 UTC+1 schrieb Shanker Balan:
> 
> > Comments inline.
> > 
> > > On 23-Jan-2017, at 4:49 PM, Marius Pfeffer [pfeffer...@gmail.com](mailto:pfeffer...@gmail.com) wrote:
> > > 
> > > I’m trying to get sensu working on a Fedora 24 Xfce machine, according to this tutorial: [http://techblog.geir.io/standalone-sensu-server-on-centos7](http://techblog.geir.io/standalone-sensu-server-on-centos7)
> > 
> > > But starting sensu-server fails via systemct:
> > > 
> > > [neo@localhost ~]$ systemctl status sensu-server  
> > > ● sensu-server.service - LSB: Sensu monitoring framework server  
> > > Loaded: loaded (/etc/rc.d/init.d/sensu-server; bad; vendor preset: disabled)  
> > > Active: failed (Result: exit-code) since Mon 2017-01-23 12:08:26 CET; 5min ago  
> > > Docs: man:systemd-sysv-generator(8)  
> > > Process: 1159 ExecStart=/etc/rc.d/init.d/sensu-server start (code=exited, status=1/FAILURE)
> > > 
> > > Jan 23 12:08:25 localhost.localdomain sensu-server[1159]: {“timestamp”:“2017-01-23T12:08:25.868351+0100”,“level”:“warn”,“message”:“loading config file”,“file”:“/etc/sensu/conf.d/uchiwa.json”}  
> > > Jan 23 12:08:25 localhost.localdomain sensu-server[1159]: {“timestamp”:“2017-01-23T12:08:25.868408+0100”,“level”:“warn”,“message”:“config file applied changes”,“file”:“/etc/sensu/conf.d/uchiwa.json”,“changes”:{“uchiwa”:[null,{“host”:“0.0.0.0”,“port”:3000,“refresh”:5,“user”:“admin”,“pass”:“REDACTED”}]}}  
> > > Jan 23 12:08:25 localhost.localdomain sensu-server[1159]: {“timestamp”:“2017-01-23T12:08:25.868473+0100”,“level”:“fatal”,“message”:“sensu must be a hash”,“object”:[{“name”:“Datacenter 1”,“host”:“localhost”,“port”:4567},{“name”:“DataCenter 1”,“host”:“127.0.0.1”,“port”:4567}]}  
> > > Jan 23 12:08:25 localhost.localdomain sensu-server[1159]: {“timestamp”:“2017-01-23T12:08:25.868509+0100”,“level”:“fatal”,“message”:“SENSU NOT RUNNING!”}  
> > > Jan 23 12:08:25 localhost.localdomain runuser[1170]: pam\_unix(runuser:session): session closed for user sensu  
> > > Jan 23 12:08:26 localhost.localdomain sensu-server[1159]: [17B blob data]  
> > > Jan 23 12:08:26 localhost.localdomain systemd[1]: sensu-server.service: Control process exited, code=exited status=1  
> > > Jan 23 12:08:26 localhost.localdomain systemd[1]: Failed to start LSB: Sensu monitoring framework server.  
> > > Jan 23 12:08:26 localhost.localdomain systemd[1]: sensu-server.service: Unit entered failed state.  
> > > Jan 23 12:08:26 localhost.localdomain systemd[1]: sensu-server.service: Failed with result ‘exit-code’.
> > > 
> > > Any ideas?
> > 
> > Did you have by any chance uchiwa.json and dashboard.json under /etc/sensu/conf.d? I dont  
> > have a dashboard.json but uchiwa.json is at /etc/sensu and not under /etc/sensu/conf.d/.
> > 
> > Do try moving the said config out of /etc/sensu/conf.d.
> > 
> > Regards.  
> > @shankerbalan

---

<div class="post-metadata">

**Author:** ![jspaleta](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.sensu.io/jspaleta/32/141_2.png) [@jspaleta](https://discourse.sensu.io/u/jspaleta)\
**Post date:** [November 22, 2018, 2:07am UTC](https://discourse.sensu.io/t/sensu-must-be-a-hash-error-while-starting-sensu-server/750/4 "2018-11-22T02:07:45Z")

</div>


