# Sensuctl configure error

**URL:** <https://discourse.sensu.io/t/sensuctl-configure-error/2731>\
**Category:** Sensu Go\
**Created:** [November 3, 2021, 4:01pm UTC](https://discourse.sensu.io/t/sensuctl-configure-error/2731 "2021-11-03T16:01:45Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![cwooley](https://avatars.discourse-cdn.com/v4/letter/c/aeb1de/32.png) [@cwooley](https://discourse.sensu.io/u/cwooley)\
**Post date:** [November 3, 2021, 4:01pm UTC](https://discourse.sensu.io/t/sensuctl-configure-error/2731/1 "2021-11-03T16:01:45Z")

</div>

Running Sensu-Backend in podman container. Attempting to run the sensuctl configure -n however I get thrown an error. “Error: unable to authenticate with error: could not unmarshal response from server: invalid character ‘\<’ looking for beginning of value”

I am brand new to sensu and just trying to monitor disk usage on several remote servers. the backend is running, and initialized as I can login to the webUI and can add entities which the agent is running on.

---

<div class="post-metadata">

**Author:** ![aaronsachs](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.sensu.io/aaronsachs/32/47_2.png) [@aaronsachs](https://discourse.sensu.io/u/aaronsachs)\
**Post date:** [November 3, 2021, 4:12pm UTC](https://discourse.sensu.io/t/sensuctl-configure-error/2731/2 "2021-11-03T16:12:22Z")

</div>

Hey there, can you walk us through how you configured sensuctl? Also, what’s your Podman configuration look like for Sensu?

---

<div class="post-metadata">

**Author:** ![cwooley](https://avatars.discourse-cdn.com/v4/letter/c/aeb1de/32.png) [@cwooley](https://discourse.sensu.io/u/cwooley)\
**Post date:** [November 4, 2021, 2:16pm UTC](https://discourse.sensu.io/t/sensuctl-configure-error/2731/3 "2021-11-04T14:16:13Z")

</div>

I have a VM hosting the backend container and an agent container. I also have sensuctl-go-cli installed from binaries on the same VM (running rhel 7.9). I spin up the backend which the web UI and HTTP API both work as expected and report healthy.

However when I run sensuctl configure (on the VM not in the container, although this happens in the container as well), it errors with: " unable to authenticate with error: could not unmarshal response from server: invalid character ‘\<’ looking for beginning of value"

---

<div class="post-metadata">

**Author:** ![cwooley](https://avatars.discourse-cdn.com/v4/letter/c/aeb1de/32.png) [@cwooley](https://discourse.sensu.io/u/cwooley)\
**Post date:** [November 4, 2021, 2:18pm UTC](https://discourse.sensu.io/t/sensuctl-configure-error/2731/4 "2021-11-04T14:18:41Z")

</div>

Im wondering if this a go interpreter issue on the VM im running. What are the dependencies for sensuctl-go-cli? I installed via yum to manage the deps but I cant find anything on this issue.

---

<div class="post-metadata">

**Author:** ![cwooley](https://avatars.discourse-cdn.com/v4/letter/c/aeb1de/32.png) [@cwooley](https://discourse.sensu.io/u/cwooley)\
**Post date:** [November 4, 2021, 3:27pm UTC](https://discourse.sensu.io/t/sensuctl-configure-error/2731/5 "2021-11-04T15:27:14Z")

</div>

solved. That error is very misleading, in my case it was a result of the API not existing by its IP or even domain name since all http requests on this machine execute via proxy. Once I fed it through with its FQDN it worked.
