Alerts showing Invalid check arguments a warnings

We are running latest version of Sensu and the alerts are being sent to Moogsoft as a way to use its integration with servicenow and other tools to create tickets. We are seeing a large number of the attached messages. Essentially they are

Invalid check argument(s): invalid option: -p, ["/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/mixlib-cli-1.7.0/mixlib/cli.rb:230:in ‘parse_options’", “/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/sensu-plugin-1.4.5/lib/sensu-plugin/cli.rb:13:in ‘initialze’”, “/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/sensu-plugin-1.4.5/lib/sensu-plugin/cli.rb:57:in ‘new’”, “/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/sensu-plugin-1.4.5/lib/sensu-plugin/cli.rb:57:in ‘block in class:CLI’”]

Has anyone seen this? How to fix this issue to remove from alerts

You may want to help us help you by adding the command you call (of course, after redacting sensitive information). That way one could see which check the -p option belongs to.

···

On Monday, July 10, 2017 at 9:17:17 PM UTC+2, Eric Tice wrote:

We are running latest version of Sensu and the alerts are being sent to Moogsoft as a way to use its integration with servicenow and other tools to create tickets. We are seeing a large number of the attached messages. Essentially they are

Invalid check argument(s): invalid option: -p, ["/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/mixlib-cli-1.7.0/mixlib/cli.rb:230:in ‘parse_options’", “/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/sensu-plugin-1.4.5/lib/sensu-plugin/cli.rb:13:in ‘initialze’”, “/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/sensu-plugin-1.4.5/lib/sensu-plugin/cli.rb:57:in ‘new’”, “/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/sensu-plugin-1.4.5/lib/sensu-plugin/cli.rb:57:in ‘block in class:CLI’”]

Has anyone seen this? How to fix this issue to remove from alerts

I will as soon as I have it. I didn’t set it up, I have a meeting with the DevOps engineer on it today

···

On Tuesday, July 11, 2017 at 5:24:11 AM UTC-5, Alexander Skiba wrote:

You may want to help us help you by adding the command you call (of course, after redacting sensitive information). That way one could see which check the -p option belongs to.

On Monday, July 10, 2017 at 9:17:17 PM UTC+2, Eric Tice wrote:

We are running latest version of Sensu and the alerts are being sent to Moogsoft as a way to use its integration with servicenow and other tools to create tickets. We are seeing a large number of the attached messages. Essentially they are

Invalid check argument(s): invalid option: -p, ["/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/mixlib-cli-1.7.0/mixlib/cli.rb:230:in ‘parse_options’", “/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/sensu-plugin-1.4.5/lib/sensu-plugin/cli.rb:13:in ‘initialze’”, “/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/sensu-plugin-1.4.5/lib/sensu-plugin/cli.rb:57:in ‘new’”, “/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/sensu-plugin-1.4.5/lib/sensu-plugin/cli.rb:57:in ‘block in class:CLI’”]

Has anyone seen this? How to fix this issue to remove from alerts

We were able to find the issue. It was a command being called that had been fat fingered. Thank you for the quick response

···

On Tuesday, July 11, 2017 at 12:56:47 PM UTC-5, Eric Tice wrote:

I will as soon as I have it. I didn’t set it up, I have a meeting with the DevOps engineer on it today

On Tuesday, July 11, 2017 at 5:24:11 AM UTC-5, Alexander Skiba wrote:

You may want to help us help you by adding the command you call (of course, after redacting sensitive information). That way one could see which check the -p option belongs to.

On Monday, July 10, 2017 at 9:17:17 PM UTC+2, Eric Tice wrote:

We are running latest version of Sensu and the alerts are being sent to Moogsoft as a way to use its integration with servicenow and other tools to create tickets. We are seeing a large number of the attached messages. Essentially they are

Invalid check argument(s): invalid option: -p, ["/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/mixlib-cli-1.7.0/mixlib/cli.rb:230:in ‘parse_options’", “/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/sensu-plugin-1.4.5/lib/sensu-plugin/cli.rb:13:in ‘initialze’”, “/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/sensu-plugin-1.4.5/lib/sensu-plugin/cli.rb:57:in ‘new’”, “/opt/sensu/embedded/lib/ruby/gems/2.4.0/gems/sensu-plugin-1.4.5/lib/sensu-plugin/cli.rb:57:in ‘block in class:CLI’”]

Has anyone seen this? How to fix this issue to remove from alerts