Bonsai auth kicks me out

I’ve been trying to share my asset at and I’ve got troubles.

Logged in with Github account fine, but then it failed to fetch my repositories list, so I have had to paste asset github repo address manually.
Then it failed to create an asset, and logged me out.
And after that I can’t log in anymore.

Green pop-up row at the top stating
You cannot log in because your account has been disabled by an administrator.

What is the problem ?
Is there any sort of verification process? - I haven’t got any email or so.


That’s very very odd. Is anatolijd the github account name?

Working on the problem now…

@anatolijd Can you retry now. There appears to have been a out of memory problem with the web application. I’ve restarted it and I was able to login and pull the repo info for a test github account i created.

You may need to clear the cookies and restart the browser. I think perhaps your browser got the oauth cookie from github but bonsai didn’t so may be in an inconsistent state.
I’m not seeing anatolijd in the list of known github users in bonsai right now, so I think the github auth failed for you in a weird way.

Hi Jef,

unfortunately, still does not work.
I’ve tried Chrome and Firefox, cleared cookie and cache, used incognito windows - lo luck.

Could that be some github account privacy settings missing or incomplete, perhaps ?

yeah maybe something on github’s side.
So in your github account look in your account profile settings…
under Applications there is an Authorized Oauth Apps tabs…

Do you see Bonsai listed? You might try revoking that oauth… logout of bonsai and rsignin and run the oauth again. I just did this with my account to ensure it worksforme.

no luck.

Me start thinking this is something to do with multiple organizations my github account is a member of.
I authorize Bonsai OAuth App to access to my personal public repos, but my organizations won’t authorize it to access their public repos.

I’ll create another github account just for Sensu assets and try again.

What’s the github account name?

If you have bonsai auth’d to see your personal repos… does bonsai see those?
Yeah if bonsai doesnt have auth to read the repos in the org, it can’t list them…but it definitely should see your personal repos.

here is the asset repo I want to share at bonsai :

I don’t see the account anatolijd in bonsai so I’m still not sure what is going on. I’ll keep trying to dig into it.

In the meantime until this is sorted out, I could offer to fork this repo and then register the fork with bonsai. It’s not ideal, but it at least gets this repository unstuck.