clients are gone; rabbitmq error

#1

I’m not sure what happened but some time in the morning 2 days ago, my sensu clients are blank. I’m seeing the below in the rabbitmq.logs. Any thoughts great appreciated.

=ERROR REPORT==== 24-Jun-2016::19:42:54 ===

SSL: hello: tls_handshake.erl:218:Fatal error: protocol version - ssl_v2_client_hello_no_supported

#2

To clarify, in Uchiwa, all of the client nodes are gone. and looking at sensu-server.llog it appears that sensu isn’t polling information for any clients.

···

On Friday, June 24, 2016 at 3:45:11 PM UTC-4, Bao Nguyen wrote:

I’m not sure what happened but some time in the morning 2 days ago, my sensu clients are blank. I’m seeing the below in the rabbitmq.logs. Any thoughts great appreciated.

=ERROR REPORT==== 24-Jun-2016::19:42:54 ===

SSL: hello: tls_handshake.erl:218:Fatal error: protocol version - ssl_v2_client_hello_no_supported

#3

Hi !

Same issue here, after an erlang + rabbitmq upgrade.

I’ve tried to downgrade to rabbitmq 3.6.1 + erlang nox 1.18 but It still don’t work.

···

On Friday, 24 June 2016 21:45:11 UTC+2, Bao Nguyen wrote:

I’m not sure what happened but some time in the morning 2 days ago, my sensu clients are blank. I’m seeing the below in the rabbitmq.logs. Any thoughts great appreciated.

=ERROR REPORT==== 24-Jun-2016::19:42:54 ===

SSL: hello: tls_handshake.erl:218:Fatal error: protocol version - ssl_v2_client_hello_no_supported

#4

I had the same issue, then resolved by upgrading:

Sensu 0.25.5-1

Rabbitmq 3.6.1

Erlang/OTP 19

···

On Friday, 24 June 2016 13:45:11 UTC-6, Bao Nguyen wrote:

I’m not sure what happened but some time in the morning 2 days ago, my sensu clients are blank. I’m seeing the below in the rabbitmq.logs. Any thoughts great appreciated.

=ERROR REPORT==== 24-Jun-2016::19:42:54 ===

SSL: hello: tls_handshake.erl:218:Fatal error: protocol version - ssl_v2_client_hello_no_supported