How to configure keepalive flap threshold?

I don’t know how to set keepalive high/low_flap_threshold.

  1. What have you already tried? Please include links to gists and/or code blocks (if relatively small)
    Checked sensuctl check list | grep -i keepalive is not hit.
    Checked sensuctl event info <agent> keepalive shows event information include below. But I couldn’t set these configuration manually.
    "high_flap_threshold": 0,
    "low_flap_threshold": 0,
  1. Tell us about your setup, this should include OS, version of Sensu, version of Sensu components (redis, rabbitmq), plugin versions (if applicable), anything special about your setup such as an airgapped network or strict ACLs
    I use 5.11.0 backend, agent and cli.

  2. Is there a Github issue related to your issue?

  3. Is there anything else that can help us effectively help you?
    Sorry, nothing.


I don’t think you can set a flapping thresholds for the keepalive event that is emitted by the agent.

I’m not sure anyone anticipated the need for applyiing the flapping algorithm to agent keepalives. Can you describe your use case? Do you have an agent that is sporadically offline?

If I think carefully, as you say.
I want to reduce keepalive alert with short time hang(hard to detecte for our department like maintenance, operation, release by another department), but I have to set timeout variable not flap threshold.

Sorry for waste your time.

1 Like

Thanks for replying and letting us know you figured this out, @eshimizu. :+1: Can you also mark this as “solved”? To do so, just click the “…” button on the comment with the solution (probably your reply?) and then click the checkbox icon. Thanks!

OK, I checked solution checkbox with my reply.

1 Like

Thanks again @eshimizu :+1: