Sensu Elasticsearch plugin


#1

Hi All:
we are trying out Sense for the first time within our development env. and we have been trying to use the elasticsearch plugins. WE noticed the following issues :

  1. that the elasticsearch plugin seems to still use the ES1.x query DSL.
  2. the plugin accepts queries against only 1 field and that the -query option to the script seems to work only in conjunction with the -f (field) option.
    My question(s) is/are as follows:
  • Is there an anticipated update to the elasticsearch query plugin so it is compatible with ES2.x ?
  • How would I go about querying against more than one field ?

Thanks for all the assistance

Cheers

Ramdev