Checks not running after introducing splay to the definition

i have a group of proxy checks… when i add splay to them, they don’t run. when i remove the splay they do run. the spec is:

  "proxy_requests": {
    "splay": true,
    "splay_coverage": 65

if i remove the proxy_requests block, they will run fine when added back, i get the following in the backed logs:

{“check”:“CHECKNAME”,“component”:“schedulerd”,“level”:“warning”,“msg”:“no matching entities, check will not be published”,“namespace”:“default”,“time”:“2019-11-04T21:10:19Z”}

  1. What have you already tried? removing the splay option
  2. Sensu backend/agent version 5.13.1 - amazon linux

Related question, are you using token substitution in your check command?

I am not. However I got my answer on the slack, In order to use splay with proxy checks, I need to specify some entity attributes to match. This isn’t perfect for me and my use case, but it makes sense in how it’s implemented. I might just stagger my intervals, to create my own “splay”