No data available in Uchiwa Dashboard, but checks are running

Hi,
Uchiwa dashboard was perfectly running since 2016 without any issues, but now there are no data in the uchiwa dashboard. It gives the error message " Datacenter returned: Connection error. Is the Sensu API running? "
The data visibility is not available in Uchiwa Dashboard, but the client and server checks are running and sending email and SMS notifications without any issues.

Logs from /var/log/uchiwa.log

{“timestamp”:“2022-01-11T21:12:30.19757092+03:00”,“level”:“warn”,“message”:“GET http://:4567/events returned: Get http://:4567/events: net/http: request canceled (Client.Timeout exceeded while awaiting headers)”}
{“timestamp”:“2022-01-11T21:12:30.197655425+03:00”,“level”:“warn”,“message”:"Connection failed to the datacenter "}

log from /var/log/sensu/sensu-api.log
{“timestamp”:“2022-01-11T21:14:39.450214+0300”,“level”:“info”,“message”:“GET /stashes”,“remote_address”:"",“user_agent”:“Go-http-client/1.1”,“request_method”:“GET”,“request_uri”:"/stashes",“request_body”:""}

I tried the below links, but no changes.

I am using the below versions
Uchiwa 0.14.1
Sensu 0.21.0 release 2
redis-cli 2.4.10
RabbitMQ 3.6.0
OS: Red Hat Enterprise Linux Server release 6.9

I have two servers, the first server has Sensu-client, sensu-server, sensu-api & Uchiwa)
Second Server has RabbitMQ and Redis.
I have restarted all the services (sensu-client, sensu-server, sensu-api,uchiwa, rabbitmq & redis) , also did “redis-cli FLUSHALL”. Rebooted the server itself. No change.

Config of Uchiwa
{
“sensu”: [
{
“name”: “DC Name”,
“host”: “IP Address of the Server”,
“port”: 4567,
“timeout”: 15 # It was 5 before, I just increased to 15 to troubleshoot, but not worked.
}
],
“uchiwa”: {
“host”: “0.0.0.0”, # Also tried with ServerIP and 127.0.0.1, not worked.
“port”: 3000,
“interval”: 5,
“users”: [

Please need your support and thank you in advance. I would really appreciate your help!
Thanks & Regards,