RabbitMQ: Handshake failure


#1

Hello,

after testing Sensu with the documented SSL Certificate utility script from https://github.com/joemiller/joemiller.me-intro-to-sensu I’m heading to deploy a sensu setup with our corporate certificates.
But I can’t make them accepted by RabbitMQ.
What settings/parameters am I missing in my Certificates that RabbitMQ is allowing me to connect with a client certificate??

Running openssl s_client/s_server tests are good with my certificates.
RabbitMQ is booting up with my certificates.
Sensu, openssel s_client or any other ssl client program are not able to establish a connection with rabbitmq.

openssl tells me about “alert number 40”. RabbitMQ logs about “{tls_alert,“handshake failure”}} (unknown POSIX error)”.

Those error messages are not very useful - as far as googled about it…

I’m not able to bring rabbitMQ into a more verbose logging mode. May you can tell me how?
In the erlang community is not much information which could be understood from a not-erlang-programmer…

Please help me understand my Problem.

Thanks,
G.D.


#2

Check your rabbitmq port configuration, you may be using the wrong port to connect to rabbitmq.

···

понедельник, 8 сентября 2014 г., 21:57:49 UTC+6 пользователь Günter Dressel написал:

Hello,

after testing Sensu with the documented SSL Certificate utility script from https://github.com/joemiller/joemiller.me-intro-to-sensu I’m heading to deploy a sensu setup with our corporate certificates.
But I can’t make them accepted by RabbitMQ.
What settings/parameters am I missing in my Certificates that RabbitMQ is allowing me to connect with a client certificate??

Running openssl s_client/s_server tests are good with my certificates.
RabbitMQ is booting up with my certificates.
Sensu, openssel s_client or any other ssl client program are not able to establish a connection with rabbitmq.

openssl tells me about “alert number 40”. RabbitMQ logs about “{tls_alert,“handshake failure”}} (unknown POSIX error)”.

Those error messages are not very useful - as far as googled about it…

I’m not able to bring rabbitMQ into a more verbose logging mode. May you can tell me how?
In the erlang community is not much information which could be understood from a not-erlang-programmer…

Please help me understand my Problem.

Thanks,
G.D.


#3

Just joined the mailing list to complain about the exact same handshake error.
Running RabbitMQ 3.3.5 on Erlang 17 and sensu-api is unable to connect to RabbitMQ with certs generated using this guide: http://sensuapp.org/docs/latest/certificates

···

On Monday, September 8, 2014 6:57:49 PM UTC+3, Günter Dressel wrote:

Hello,

after testing Sensu with the documented SSL Certificate utility script from https://github.com/joemiller/joemiller.me-intro-to-sensu I’m heading to deploy a sensu setup with our corporate certificates.
But I can’t make them accepted by RabbitMQ.
What settings/parameters am I missing in my Certificates that RabbitMQ is allowing me to connect with a client certificate??

Running openssl s_client/s_server tests are good with my certificates.
RabbitMQ is booting up with my certificates.
Sensu, openssel s_client or any other ssl client program are not able to establish a connection with rabbitmq.

openssl tells me about “alert number 40”. RabbitMQ logs about “{tls_alert,“handshake failure”}} (unknown POSIX error)”.

Those error messages are not very useful - as far as googled about it…

I’m not able to bring rabbitMQ into a more verbose logging mode. May you can tell me how?
In the erlang community is not much information which could be understood from a not-erlang-programmer…

Please help me understand my Problem.

Thanks,
G.D.