Sensu-api running but health sucks, throwing errors into Uchiwa


#1

Hi,

My uchiwa comes up just fine.

RabbitMQ also.

But sensu-api? That thing is driving me nuts!

It says something is wrong with sensu-api - I can’t find what.

I’m left standing asking it “baby … what’s wrong!?” over and over.

The logs don’t help much …

I’ve reviewed the .json files.

I’m missing something but I haven’t been able to find it and the tools I have aren’t dropping enough hints about where to look.

I’ve got the the health checks to look at -

/health

{"uchiwa":"ok","sensu":{"Sensu":{}}}

/health/sensu

{"sensu":{"Sensu":{}}}

/health/uchiwa

{"uchiwa":"ok"}

but no clues or pointers to where to dig in.

Mainly, uchiwa says, “Error with Sensu API Sensu” and that’s it. Even

https://www.google.com/search?q="Error%20with%20Sensu%20API%20Sensu"

is no help.

Hope someone here is!

Thanks so much!!!


#2

FIXED - replaced /etc/sensu/conf.d/*.json files with (near) stock copy of config.json.example

···

On Wednesday, October 15, 2014 10:32:21 AM UTC-5, clay tyler wrote:

Hi,

My uchiwa comes up just fine.

RabbitMQ also.

But sensu-api? That thing is driving me nuts!

It says something is wrong with sensu-api - I can’t find what.

I’m left standing asking it “baby … what’s wrong!?” over and over.

The logs don’t help much …

I’ve reviewed the .json files.

I’m missing something but I haven’t been able to find it and the tools I have aren’t dropping enough hints about where to look.

I’ve got the the health checks to look at -

/health

{"uchiwa":"ok","sensu":{"Sensu":{}}}

/health/sensu

{"sensu":{"Sensu":{}}}

/health/uchiwa

{"uchiwa":"ok"}

but no clues or pointers to where to dig in.

Mainly, uchiwa says, “Error with Sensu API Sensu” and that’s it. Even

https://www.google.com/search?q=%22Error%20with%20Sensu%20API%20Sensu%22

is no help.

Hope someone here is!

Thanks so much!!!