unable to start api: "sensu-service api start" [fail]


#1

I’m new to sensu, trying to get things up and running.

I started the server, seems to be running (i can see good stuff in /var/log/sensu/sensu-server.log) when I tried

to start the api, it takes a second, then fails with this in the log:

“default”],“command”:"/etc/sensu/plugins/check-procs.rb -p crond -C 1 ",“interval”:60,“subscribers”:[“webservers”]}]}}}

{“timestamp”:“2014-09-23T10:16:07.680041-0400”,“level”:“fatal”,“message”:“invalid settings”}

{“timestamp”:“2014-09-23T10:16:07.680126-0400”,“level”:“fatal”,“message”:“api must be a hash”,“object”:null}

{“timestamp”:“2014-09-23T10:16:07.680188-0400”,“level”:“fatal”,“message”:“SENSU NOT RUNNING!”}

“SENSU NOT RUNNING” doesn’t sound good?

What do I do?

Thanks.


#2

My mistake, I didn’t create the api.json file, it started fine now. Sorry.

···

On Tuesday, September 23, 2014 10:21:17 AM UTC-4, Eric Fontana wrote:

I’m new to sensu, trying to get things up and running.

I started the server, seems to be running (i can see good stuff in /var/log/sensu/sensu-server.log) when I tried

to start the api, it takes a second, then fails with this in the log:

“default”],“command”:"/etc/sensu/plugins/check-procs.rb -p crond -C 1 ",“interval”:60,“subscribers”:[“webservers”]}]}}}

{“timestamp”:“2014-09-23T10:16:07.680041-0400”,“level”:“fatal”,“message”:“invalid settings”}

{“timestamp”:“2014-09-23T10:16:07.680126-0400”,“level”:“fatal”,“message”:“api must be a hash”,“object”:null}

{“timestamp”:“2014-09-23T10:16:07.680188-0400”,“level”:“fatal”,“message”:“SENSU NOT RUNNING!”}

“SENSU NOT RUNNING” doesn’t sound good?

What do I do?

Thanks.