Windows embedded ruby version


#1

Currently the windows embedded ruby version is 2.0.0 and the linux version is 2.3.0 (both using sensu 0.23.2).

The current version of RubyInstaller is Ruby 2.3.0 and Ruby 2.0.0 is EoL.

Should the versions of embedded ruby be kept in sync across all platforms?

Cheers,

Joel


#2

Yes, the Windows packages should include a non-EOL version of Ruby. There’s an issue for updating it: https://github.com/sensu/sensu-build/issues/161

···

On Tue, May 10, 2016 at 8:02 AM, joel.smith1@hscic.gov.uk wrote:

Currently the windows embedded ruby version is 2.0.0 and the linux version is 2.3.0 (both using sensu 0.23.2).

The current version of RubyInstaller is Ruby 2.3.0 and Ruby 2.0.0 is EoL.

Should the versions of embedded ruby be kept in sync across all platforms?

Cheers,

Joel