Ruby 1.9.3 EOL


#1

Ruby 1.9.3 will be end-of-life on February 23, what are thoughts on continuing to test/build against it.

I have no problems with keeping it going as a lot of people will still be using it but on the other hand, it is trivial to use the embedded Ruby which is 2X. I will leave it up to the community to decide but my vote is to leave testing and building against it for at least another year, if nothing more it will at least ensure backwards compatibility for anything new that drops.

I do recommend and will amend the readme that if your system is not running at least Ruby 2.0.0, you use the embedded Ruby to ensure the highest possible reliability.

Any one else want to chime in?


#2

I don’t see any real major problem with continuing to test against 1.9.3 for now, but there should be no real effort to ensure continued support/functionality. Just drop a notice when it breaks.

Perhaps all of the plugins in the git repo should be made to point @ #! /opt/sensu/embedded/bin/ruby instead of "#! /usr/bin/env ruby’?

···

On Thursday, January 15, 2015 at 9:36:23 PM UTC-7, Matt Jones wrote:

Ruby 1.9.3 will be end-of-life on February 23, what are thoughts on continuing to test/build against it.

I have no problems with keeping it going as a lot of people will still be using it but on the other hand, it is trivial to use the embedded Ruby which is 2X. I will leave it up to the community to decide but my vote is to leave testing and building against it for at least another year, if nothing more it will at least ensure backwards compatibility for anything new that drops.

I do recommend and will amend the readme that if your system is not running at least Ruby 2.0.0, you use the embedded Ruby to ensure the highest possible reliability.

Any one else want to chime in?


#3

The issue with setting that in the header is what happens if I am running these on a machine without sensu installed or non-linux box or any number of other reasons. I would strongly oppose this and if people wanted to do this then they should follow the instructions in the readme for setting the embedded ruby in their environment.

The thought is a good one and in a perfect world I would say the right one but in the wild that will get ugly and breaks some common conventions on script writing.

I will leave 1.9.2 and 1.9.3 in the build matrix for now but from my point of view I am thinking only one EOL version should be maintained at any given time. With that being said I will remove 1.8.7 from the build matrix completely. If a test fails for 1.9x then the script can be marked as such and if someone wants to make a PR and fix it then by all means it will be accepted. I myself generally only write 2x Ruby but most of it will work on 1.9x without modification. Just my two cents, feel free to call me crazy.

···

On Fri, Jan 16, 2015 at 12:07 PM, awpti@awpti.org wrote:

I don’t see any real major problem with continuing to test against 1.9.3 for now, but there should be no real effort to ensure continued support/functionality. Just drop a notice when it breaks.

Perhaps all of the plugins in the git repo should be made to point @ #! /opt/sensu/embedded/bin/ruby instead of "#! /usr/bin/env ruby’?

On Thursday, January 15, 2015 at 9:36:23 PM UTC-7, Matt Jones wrote:

Ruby 1.9.3 will be end-of-life on February 23, what are thoughts on continuing to test/build against it.

I have no problems with keeping it going as a lot of people will still be using it but on the other hand, it is trivial to use the embedded Ruby which is 2X. I will leave it up to the community to decide but my vote is to leave testing and building against it for at least another year, if nothing more it will at least ensure backwards compatibility for anything new that drops.

I do recommend and will amend the readme that if your system is not running at least Ruby 2.0.0, you use the embedded Ruby to ensure the highest possible reliability.

Any one else want to chime in?