Does anyone have experience securing the Dashboard with a cert from Let's Encrypt? -- Solved

I’m struggling mightily to secure my dashboard with a cert from Let’s Encrypt.

I am using docker-compose to run my sensu-go instance and in the command, I am setting --dashboard-cert-file and --dashboard-key-file with the appropriate paths. Sadly, there is log output that states that there is no such file or directory. I have this properly configured in nginx so it is probably just a matter of permissions.

Thanks for any help or insight that someone may be able to provide.

1 Like

I’m an extreme novice when it comes to docker and it is quite possible that the file just actually doesn’t exist because I’m not making it available to the image. Stay tuned…

1 Like

Are you volume mounting the certs into the Docker container? Can you share your Dockerfile and docker run command?

That was actually the issue. I was not mounting the certs. One of my colleagues politely pointed that out when I was going over the situation.

Once I properly mounted the certs, things worked as expected.

Thanks for reaching out @calebhailey.


1 Like

Happy to help! :+1: Glad you got it sorted out!