Newbie question: Can't see new client on Uchiwa dashboard.

#1

Hi All,
I’m starting to use Sensu and I’m hitting a blocker. I’ve installed the Sensu stack on an Ubuntu machine and am attempting to connect a Windows client to the server.

The internal client on the server shows up just fine on the dashboard, but my Windows client is nowhere to be seen. I think that the client is connecting via RabbitMQ correctly since I see the following on the client’s sensu-client.log:

2016-06-07T15:28:44.727771-0400",“level”:“warn”,“message”:“received signal”,“signal”:“INT”}

{“timestamp”:“2016-06-07T15:28:44.727771-0400”,“level”:“warn”,“message”:“stopping”}

{“timestamp”:“2016-06-07T15:28:45.242572-0400”,“level”:“warn”,“message”:“stopping reactor”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading config file”,“file”:“C:\opt\sensu\config.json”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading config files from directory”,“directory”:“C:\opt\sensu\conf.d”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading config file”,“file”:“C:/opt/sensu/conf.d/client.json”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“config file applied changes”,“file”:“C:/opt/sensu/conf.d/client.json”,“changes”:{“client”:[null,{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{}}]}}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading extension files from directory”,“directory”:"C:\opt\sensu\

I looked at the rabbitmq log and I see the connection is accepted: (Ignore the timestamp. The two machines are not time synced.)

=INFO REPORT==== 7-Jun-2016::12:28:48 ===

accepting AMQP connection <0.2413.0> (192.168.128.131:49299 -> 192.168.128.129:5672)

So my client is at 192.168.128.131 while the server is at 19.168.128.129.

I ran a wireshark trace and I see a keepalive AMQP packet being sent to the server, but my dashboard doesn’t register the external client. If I didn’t know better, I’d say that the server is not connected to the rabbitMQ service, but my config.json on the server is as follows:

{

“redis”: {

“host”: “127.0.0.1”

},

“transport”: {

“name”: “rabbitmq”,

“reconnect_on_error”: true

},

“api”: {

“host”: “127.0.0.1”,

“port”: 4567

}

}

and my rabbitmq.json is as follows:

{

“rabbitmq”: {

“host”: “192.168.128.129”,

“port”: 5672,

“vhost”: “/sensu”,

“user”: “sensu”,

“password”: “secret”,

}

}

.

On the client side, the config.json is as follows:

{

“transport”: {

“reconnect_on_error”: true

},

“rabbitmq”: {

“host”: “192.168.128.129”,

“port”: 5672,

“vhost”: “/sensu”,

“user”: “sensu”,

“password”: “secret”

},

“redis”: {

“host”: “localhost”,

“port”: 6379,

“reconnect_on_error”: true

},

“api”: {

“host”: “localhost”,

“bind”: “0.0.0.0”,

“port”: 4567

}

}

So as far as I can see everything is configured correctly. Is there anything I’m missing or can anybody suggest how I might proceed to troubleshoot this issue?

Regards,

-Jose Corpuz

#2

Hi Jose,

I think you’ll need to register this client before.

Do you have a client.json on your Windows?

regards

João Gabriel Lisanti

···

On Tuesday, June 7, 2016 at 6:22:13 PM UTC-3, Jose Corpuz wrote:

Hi All,
I’m starting to use Sensu and I’m hitting a blocker. I’ve installed the Sensu stack on an Ubuntu machine and am attempting to connect a Windows client to the server.

The internal client on the server shows up just fine on the dashboard, but my Windows client is nowhere to be seen. I think that the client is connecting via RabbitMQ correctly since I see the following on the client’s sensu-client.log:

2016-06-07T15:28:44.727771-0400",“level”:“warn”,“message”:“received signal”,“signal”:“INT”}

{“timestamp”:“2016-06-07T15:28:44.727771-0400”,“level”:“warn”,“message”:“stopping”}

{“timestamp”:“2016-06-07T15:28:45.242572-0400”,“level”:“warn”,“message”:“stopping reactor”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading config file”,“file”:“C:\opt\sensu\config.json”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading config files from directory”,“directory”:“C:\opt\sensu\conf.d”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading config file”,“file”:“C:/opt/sensu/conf.d/client.json”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“config file applied changes”,“file”:“C:/opt/sensu/conf.d/client.json”,“changes”:{“client”:[null,{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{}}]}}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading extension files from directory”,“directory”:"C:\opt\sensu\

I looked at the rabbitmq log and I see the connection is accepted: (Ignore the timestamp. The two machines are not time synced.)

=INFO REPORT==== 7-Jun-2016::12:28:48 ===

accepting AMQP connection <0.2413.0> (192.168.128.131:49299 -> 192.168.128.129:5672)

So my client is at 192.168.128.131 while the server is at 19.168.128.129.

I ran a wireshark trace and I see a keepalive AMQP packet being sent to the server, but my dashboard doesn’t register the external client. If I didn’t know better, I’d say that the server is not connected to the rabbitMQ service, but my config.json on the server is as follows:

{

“redis”: {

“host”: “127.0.0.1”

},

“transport”: {

“name”: “rabbitmq”,

“reconnect_on_error”: true

},

“api”: {

“host”: “127.0.0.1”,

“port”: 4567

}

}

and my rabbitmq.json is as follows:

{

“rabbitmq”: {

“host”: “192.168.128.129”,

“port”: 5672,

“vhost”: “/sensu”,

“user”: “sensu”,

“password”: “secret”,

}

}

.

On the client side, the config.json is as follows:

{

“transport”: {

“reconnect_on_error”: true

},

“rabbitmq”: {

“host”: “192.168.128.129”,

“port”: 5672,

“vhost”: “/sensu”,

“user”: “sensu”,

“password”: “secret”

},

“redis”: {

“host”: “localhost”,

“port”: 6379,

“reconnect_on_error”: true

},

“api”: {

“host”: “localhost”,

“bind”: “0.0.0.0”,

“port”: 4567

}

}

So as far as I can see everything is configured correctly. Is there anything I’m missing or can anybody suggest how I might proceed to troubleshoot this issue?

Regards,

-Jose Corpuz

#3

Hi João,

Yes, I have a client.json on the Windows client. It is as follows:

{

“client”: {

“name”: “Windows-Test”,

“address”: “192.168.128.131”,

“environment”: “development”,

“subscriptions”: [

“dev”

],

"keepalive":{

}

}

}

The server log reports the client making a connection via RabbitMQ. From /var/log/rabbitMQ/rabbit@ubuntu.log:
=INFO REPORT==== 8-Jun-2016::18:17:22 ===

accepting AMQP connection <0.6868.0> (192.168.128.131:49493 -> 192.168.128.129:5672)

The client log on the Windows machine is as follows:

{“timestamp”:“2016-06-08T21:17:21.724387-0400”,“level”:“warn”,“message”:“loading config file”,“file”:“C:\opt\sensu\config.json”}

{“timestamp”:“2016-06-08T21:17:21.724387-0400”,“level”:“warn”,“message”:“loading config files from directory”,“directory”:“C:\opt\sensu\conf.d”}

{“timestamp”:“2016-06-08T21:17:21.724387-0400”,“level”:“warn”,“message”:“loading config file”,“file”:“C:/opt/sensu/conf.d/client.json”}

{“timestamp”:“2016-06-08T21:17:21.724387-0400”,“level”:“warn”,“message”:“config file applied changes”,“file”:“C:/opt/sensu/conf.d/client.json”,“changes”:{“client”:[null,{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{}}]}}

{“timestamp”:“2016-06-08T21:17:21.724387-0400”,“level”:“warn”,“message”:“loading extension files from directory”,“directory”:“C:\opt\sensu\extensions”}

{“timestamp”:“2016-06-08T21:17:21.724387-0400”,“level”:“debug”,“message”:“connecting to transport”,“name”:“rabbitmq”,“settings”:{“host”:“192.168.128.129”,“port”:5672,“vhost”:"/sensu",“user”:“sensu”,“password”:“secret”}}

{“timestamp”:“2016-06-08T21:17:21.849187-0400”,“level”:“debug”,“message”:“binding client tcp and udp sockets”,“options”:{“bind”:“127.0.0.1”,“port”:3030}}

{“timestamp”:“2016-06-08T21:17:21.849187-0400”,“level”:“debug”,“message”:“scheduling keepalives”}

{“timestamp”:“2016-06-08T21:17:21.849187-0400”,“level”:“debug”,“message”:“publishing keepalive”,“payload”:{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{},“version”:“0.23.1”,“timestamp”:1465435041}}

{“timestamp”:“2016-06-08T21:17:21.849187-0400”,“level”:“debug”,“message”:“subscribing to client subscriptions”}

{“timestamp”:“2016-06-08T21:17:21.849187-0400”,“level”:“debug”,“message”:“subscribing to a subscription”,“subscription”:“dev”}

{“timestamp”:“2016-06-08T21:17:21.849187-0400”,“level”:“debug”,“message”:“scheduling standalone checks”}

{“timestamp”:“2016-06-08T21:17:41.864022-0400”,“level”:“debug”,“message”:“publishing keepalive”,“payload”:{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{},“version”:“0.23.1”,“timestamp”:1465435061}}

{“timestamp”:“2016-06-08T21:18:01.878858-0400”,“level”:“debug”,“message”:“publishing keepalive”,“payload”:{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{},“version”:“0.23.1”,“timestamp”:1465435081}}

{“timestamp”:“2016-06-08T21:18:21.893693-0400”,“level”:“debug”,“message”:“publishing keepalive”,“payload”:{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{},“version”:“0.23.1”,“timestamp”:1465435101}}

{“timestamp”:“2016-06-08T21:18:41.908528-0400”,“level”:“debug”,“message”:“publishing keepalive”,“payload”:{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{},“version”:“0.23.1”,“timestamp”:1465435121}}

So I’m confused. It seems like the error is communication between RabbitMQ and Sensu-server.

-Jose

···

On Wednesday, June 8, 2016 at 5:37:33 PM UTC-4, João Gabriel wrote:

Hi Jose,

I think you’ll need to register this client before.

Do you have a client.json on your Windows?

regards

João Gabriel Lisanti

On Tuesday, June 7, 2016 at 6:22:13 PM UTC-3, Jose Corpuz wrote:

Hi All,
I’m starting to use Sensu and I’m hitting a blocker. I’ve installed the Sensu stack on an Ubuntu machine and am attempting to connect a Windows client to the server.

The internal client on the server shows up just fine on the dashboard, but my Windows client is nowhere to be seen. I think that the client is connecting via RabbitMQ correctly since I see the following on the client’s sensu-client.log:

2016-06-07T15:28:44.727771-0400",“level”:“warn”,“message”:“received signal”,“signal”:“INT”}

{“timestamp”:“2016-06-07T15:28:44.727771-0400”,“level”:“warn”,“message”:“stopping”}

{“timestamp”:“2016-06-07T15:28:45.242572-0400”,“level”:“warn”,“message”:“stopping reactor”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading config file”,“file”:“C:\opt\sensu\config.json”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading config files from directory”,“directory”:“C:\opt\sensu\conf.d”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading config file”,“file”:“C:/opt/sensu/conf.d/client.json”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“config file applied changes”,“file”:“C:/opt/sensu/conf.d/client.json”,“changes”:{“client”:[null,{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{}}]}}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading extension files from directory”,“directory”:"C:\opt\sensu\

I looked at the rabbitmq log and I see the connection is accepted: (Ignore the timestamp. The two machines are not time synced.)

=INFO REPORT==== 7-Jun-2016::12:28:48 ===

accepting AMQP connection <0.2413.0> (192.168.128.131:49299 -> 192.168.128.129:5672)

So my client is at 192.168.128.131 while the server is at 19.168.128.129.

I ran a wireshark trace and I see a keepalive AMQP packet being sent to the server, but my dashboard doesn’t register the external client. If I didn’t know better, I’d say that the server is not connected to the rabbitMQ service, but my config.json on the server is as follows:

{

“redis”: {

“host”: “127.0.0.1”

},

“transport”: {

“name”: “rabbitmq”,

“reconnect_on_error”: true

},

“api”: {

“host”: “127.0.0.1”,

“port”: 4567

}

}

and my rabbitmq.json is as follows:

{

“rabbitmq”: {

“host”: “192.168.128.129”,

“port”: 5672,

“vhost”: “/sensu”,

“user”: “sensu”,

“password”: “secret”,

}

}

.

On the client side, the config.json is as follows:

{

“transport”: {

“reconnect_on_error”: true

},

“rabbitmq”: {

“host”: “192.168.128.129”,

“port”: 5672,

“vhost”: “/sensu”,

“user”: “sensu”,

“password”: “secret”

},

“redis”: {

“host”: “localhost”,

“port”: 6379,

“reconnect_on_error”: true

},

“api”: {

“host”: “localhost”,

“bind”: “0.0.0.0”,

“port”: 4567

}

}

So as far as I can see everything is configured correctly. Is there anything I’m missing or can anybody suggest how I might proceed to troubleshoot this issue?

Regards,

-Jose Corpuz

#4

I found the error. So that others can learn from my idiocy, here’s what I did to find the error.

I started by manually printing out the configuration hash for both the server end and windows end. This was done on the linux side by the sudo -u sensu /opt/sensu/bin/sensu-client -P -c / -d / > .

Then to get the same information dump on the Windows side I had to modify the windows c:\opt\sensu\bin\sensu-client.xml file since the client cannot be run in command line. In that file I had to add the line -P and restart the service. The service will error out but you will get the configuration in the client log. When you want the service to run correctly you will need to remove the -P argument.

I compared these two and made sure the rabbitmq settings were the same. It was also in the logs that I found that there was an error parsing the server side rabbitmq.json file. This caused the server side to connect to Rabbitmq with default user and password instead of the correct vhost and credentials I wanted.

Then finally once everything is correlated, I had to restart the sensu-client on both machines and the sensu-server on the server. I was chasing my tail for a while after I checked the configuration hashes because I only changed the client side. I forgot that both the server and client read from the same rabbitmq.json file. When I only restarted the clients, the server was still subscribed to the original vhost and consequently was not talking to my Win clients transport.

Thanks João for the help.

-Jose

···

On Wednesday, June 8, 2016 at 10:10:44 PM UTC-4, Jose Corpuz wrote:

Hi João,

Yes, I have a client.json on the Windows client. It is as follows:

{

“client”: {

“name”: “Windows-Test”,

“address”: “192.168.128.131”,

“environment”: “development”,

“subscriptions”: [

“dev”

],

“keepalive”:{

}

}

}

=INFO REPORT==== 8-Jun-2016::18:17:22 ===

accepting AMQP connection <0.6868.0> (192.168.128.131:49493 -> 192.168.128.129:5672)

The server log reports the client making a connection via RabbitMQ. From /var/log/rabbitMQ/rabbit@ubuntu.log:

The client log on the Windows machine is as follows:

{“timestamp”:“2016-06-08T21:17:21.724387-0400”,“level”:“warn”,“message”:“loading config file”,“file”:“C:\opt\sensu\config.json”}

{“timestamp”:“2016-06-08T21:17:21.724387-0400”,“level”:“warn”,“message”:“loading config files from directory”,“directory”:“C:\opt\sensu\conf.d”}

{“timestamp”:“2016-06-08T21:17:21.724387-0400”,“level”:“warn”,“message”:“loading config file”,“file”:“C:/opt/sensu/conf.d/client.json”}

{“timestamp”:“2016-06-08T21:17:21.724387-0400”,“level”:“warn”,“message”:“config file applied changes”,“file”:“C:/opt/sensu/conf.d/client.json”,“changes”:{“client”:[null,{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{}}]}}

{“timestamp”:“2016-06-08T21:17:21.724387-0400”,“level”:“warn”,“message”:“loading extension files from directory”,“directory”:“C:\opt\sensu\extensions”}

{“timestamp”:“2016-06-08T21:17:21.724387-0400”,“level”:“debug”,“message”:“connecting to transport”,“name”:“rabbitmq”,“settings”:{“host”:“192.168.128.129”,“port”:5672,“vhost”:"/sensu",“user”:“sensu”,“password”:“secret”}}

{“timestamp”:“2016-06-08T21:17:21.849187-0400”,“level”:“debug”,“message”:“binding client tcp and udp sockets”,“options”:{“bind”:“127.0.0.1”,“port”:3030}}

{“timestamp”:“2016-06-08T21:17:21.849187-0400”,“level”:“debug”,“message”:“scheduling keepalives”}

{“timestamp”:“2016-06-08T21:17:21.849187-0400”,“level”:“debug”,“message”:“publishing keepalive”,“payload”:{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{},“version”:“0.23.1”,“timestamp”:1465435041}}

{“timestamp”:“2016-06-08T21:17:21.849187-0400”,“level”:“debug”,“message”:“subscribing to client subscriptions”}

{“timestamp”:“2016-06-08T21:17:21.849187-0400”,“level”:“debug”,“message”:“subscribing to a subscription”,“subscription”:“dev”}

{“timestamp”:“2016-06-08T21:17:21.849187-0400”,“level”:“debug”,“message”:“scheduling standalone checks”}

{“timestamp”:“2016-06-08T21:17:41.864022-0400”,“level”:“debug”,“message”:“publishing keepalive”,“payload”:{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{},“version”:“0.23.1”,“timestamp”:1465435061}}

{“timestamp”:“2016-06-08T21:18:01.878858-0400”,“level”:“debug”,“message”:“publishing keepalive”,“payload”:{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{},“version”:“0.23.1”,“timestamp”:1465435081}}

{“timestamp”:“2016-06-08T21:18:21.893693-0400”,“level”:“debug”,“message”:“publishing keepalive”,“payload”:{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{},“version”:“0.23.1”,“timestamp”:1465435101}}

{“timestamp”:“2016-06-08T21:18:41.908528-0400”,“level”:“debug”,“message”:“publishing keepalive”,“payload”:{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{},“version”:“0.23.1”,“timestamp”:1465435121}}

So I’m confused. It seems like the error is communication between RabbitMQ and Sensu-server.

-Jose

On Wednesday, June 8, 2016 at 5:37:33 PM UTC-4, João Gabriel wrote:

Hi Jose,

I think you’ll need to register this client before.

Do you have a client.json on your Windows?

regards

João Gabriel Lisanti

On Tuesday, June 7, 2016 at 6:22:13 PM UTC-3, Jose Corpuz wrote:

Hi All,
I’m starting to use Sensu and I’m hitting a blocker. I’ve installed the Sensu stack on an Ubuntu machine and am attempting to connect a Windows client to the server.

The internal client on the server shows up just fine on the dashboard, but my Windows client is nowhere to be seen. I think that the client is connecting via RabbitMQ correctly since I see the following on the client’s sensu-client.log:

2016-06-07T15:28:44.727771-0400",“level”:“warn”,“message”:“received signal”,“signal”:“INT”}

{“timestamp”:“2016-06-07T15:28:44.727771-0400”,“level”:“warn”,“message”:“stopping”}

{“timestamp”:“2016-06-07T15:28:45.242572-0400”,“level”:“warn”,“message”:“stopping reactor”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading config file”,“file”:“C:\opt\sensu\config.json”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading config files from directory”,“directory”:“C:\opt\sensu\conf.d”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading config file”,“file”:“C:/opt/sensu/conf.d/client.json”}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“config file applied changes”,“file”:“C:/opt/sensu/conf.d/client.json”,“changes”:{“client”:[null,{“name”:“Windows-Test”,“address”:“192.168.128.131”,“environment”:“development”,“subscriptions”:[“dev”],“keepalive”:{}}]}}

{“timestamp”:“2016-06-07T15:28:46.334574-0400”,“level”:“warn”,“message”:“loading extension files from directory”,“directory”:"C:\opt\sensu\

I looked at the rabbitmq log and I see the connection is accepted: (Ignore the timestamp. The two machines are not time synced.)

=INFO REPORT==== 7-Jun-2016::12:28:48 ===

accepting AMQP connection <0.2413.0> (192.168.128.131:49299 -> 192.168.128.129:5672)

So my client is at 192.168.128.131 while the server is at 19.168.128.129.

I ran a wireshark trace and I see a keepalive AMQP packet being sent to the server, but my dashboard doesn’t register the external client. If I didn’t know better, I’d say that the server is not connected to the rabbitMQ service, but my config.json on the server is as follows:

{

“redis”: {

“host”: “127.0.0.1”

},

“transport”: {

“name”: “rabbitmq”,

“reconnect_on_error”: true

},

“api”: {

“host”: “127.0.0.1”,

“port”: 4567

}

}

and my rabbitmq.json is as follows:

{

“rabbitmq”: {

“host”: “192.168.128.129”,

“port”: 5672,

“vhost”: “/sensu”,

“user”: “sensu”,

“password”: “secret”,

}

}

.

On the client side, the config.json is as follows:

{

“transport”: {

“reconnect_on_error”: true

},

“rabbitmq”: {

“host”: “192.168.128.129”,

“port”: 5672,

“vhost”: “/sensu”,

“user”: “sensu”,

“password”: “secret”

},

“redis”: {

“host”: “localhost”,

“port”: 6379,

“reconnect_on_error”: true

},

“api”: {

“host”: “localhost”,

“bind”: “0.0.0.0”,

“port”: 4567

}

}

So as far as I can see everything is configured correctly. Is there anything I’m missing or can anybody suggest how I might proceed to troubleshoot this issue?

Regards,

-Jose Corpuz