/opt/sensu/bin/sensu-backend: line 3: syntax error: unterminated quoted string on armv7 (raspberry pi)

Sensu Go Topic Template
Make sure to read the docs before asking your question. Please be kind and remember that this those helping you are volunteers.

Having a problem and looking for help? Consider including:

  1. What have you already tried? Please include links to gists and/or code blocks (if relatively small)
    I ran docker run -it sensu/sensu on my machine and that works, but on my raspberry pi i get /opt/sensu/bin/sensu-backend: line 3: syntax error: unterminated quoted string
  2. Tell us about your setup, this should include OS, version of Sensu, version of Sensu components plugin versions (if applicable), anything special about your setup such as an airgapped network or strict ACLs
    Raspberry pi running rasbpian trying to use the docker image from dockerhub
  3. Is there a Github issue related to your issue?
    Not that i found
  4. Is there anything else that can help us effectively help you?
    It works on my linux machine so it seems to be an architecture problem.
  5. use the Discourse upload button to attach Sensu relevant yaml or json configuration files.
1 Like

First, let me just say wow, thanks for getting out there on the bleeding edge and trying to use Sensu on one of the unsupported platforms. We definitely appreciate the testing.

Second, this is definitely a bug in the docker build tooling. Thanks for letting us know.
We’ve got it filed now so hopefully it should be taken care next time the images are refreshed.

In the meantime, you can probably get by with cracking the docker image open and fixing the typo at the script, and then saving the fixed version as a local docker image.

Thanks for your reply! I had assumed that armv7 architectures were supported, because there’s an image on dockerhub for them. Is there some documentation that I missed that says this architecture isn’t supported?

Additionally, it doesn’t look like this has been fixed in the latest image yet. Is there an eta for when the images will be updated with this change?

The issue is fixed and merged, https://github.com/sensu/sensu-docker/issues/22

But there probably won’t be new docker images produced until the next release it cut.

It looks like we don’t provide any information concerning the experimental nature of the arm support in the docker image. But I’ll look on getting that updated to avoid confusion.

I apologize for the confusion. Both sensu-agent & sensuctl are supported on armv7 but sensu-backend is only officially supported on amd64 as per Supported platforms and distributions - Sensu Docs.

We don’t ship sensu-backend for 32-bit platforms due to a bug in the Go runtime that can affect Etcd: etcd docs | Supported systems.

We do bundle sensu-backend with the arm64 Docker image which should run on the Pi 3 & 4 so long as you’re running a 64-bit distro (e.g. Ubuntu 20.04 arm64).

Please note, however, that Etcd on arm64 is considered experimental: etcd docs | Supported systems.